Configurando o MySQL Connector com o C++ no Eclipse IDE, usando o Debian 7.2

Execute a seguinte linha de comando para instalar os pacotes necessários no seu Debian: “apt-get install mysql-5.5 g++ cmake cmake-gui boost1.54 libmysqlclient15-dev

A biblioteca libmysqlclient15-dev, impedirá a falta do executável de configuração do MYSQL (geralmente localizado em /usr/bin/mysql_config) para a operações com o CMAKE (A variável ao compilar o connector, provavelmente será: MYSQL_CONFIG_EXECUTABLE, no CMake).

Baixe o conector aqui: http://dev.mysql.com/downloads/connector/cpp/. Lembre-se, em “Select Platform“, escolha “Source Code“, e clique em Download. Não faça a besteira de escolher Debian Linux e esperar que venha com os source codes para você compilar!

Abra o terminal, vá até a pasta em que você baixou o connector, e extraia o arquivo! No nosso caso é um arquivo .tar.gz, então digitaremos: “tar -zxvf (NOME DO ARQUIVO)”, ficando assim “tar -zxvf mysql-connector-c++-1.1.3.tar.gz“.

Agora que extraímos o arquivo, vamos entrar dentro da pasta, e digitar a seguinte linha de comando: “cmake .

Caso ocorra algum erro, abra o cmake-gui e corrija os diretórios, ou veja se esqueceu de instalar alguma biblioteca.

As bibliotecas devem ficar como na foto abaixo:

Captura de tela de 2013-10-25 01:30:10

 

CMAKE_INSTALL_PREFIX=/usr/local

MYSQLCPPCONN_DYNLOAD_MYSQL_LIB=/usr/lib/x86_64-linux-gnu/libmysqlclient_r.so

MYSQL_CONFIG_EXECUTABLE=/usr/bin/mysql_config

MYSQL_INCLUDE_DIR=/usr/include/mysql

MYSQL_LIB=/usr/lib/mysql

Se tiver algum dúvida sobre qual diretório escolher, apenas note que as variáveis que possuem INCLUDE em seu nome, ficam dentro da pasta /usr/include, e as variáveis que possuem LIB, em seu nome, ficam dentro da pasta /usr/lib. Mas, por ventura acredito que possa acontecer de estar dentro da pasta local (/usr/local/lib ou /usr/local/include), apenas teste até funcionar, se não der certo: VOCÊ ESQUECEU DE INSTALAR ALGUMA BIBLIOTECA!

Então digite: “make; make install;

Quando o comando “make” começar a ser executado, você verá duas coisas importantes para fazer o seu connector funcionar:

Scanning dependencies of target mysqlcppconn

Linking CXX shared library libmysqlcppconn.so

Note que a biblioteca do connector se chama mysqlcppconn, no Windows, provavelmente teríamos alguma DLL, chamada mysqlcppconn, mas, aqui no Linux é tudo mais fácil, então você saberá o que fazer nos passos a seguir, estou apenas escrevendo isso, para que fique bem claro por que adicionaremos este “link” do eclipse.

Espere terminar, e quando estiver tudo instalado:

  1. Abra o eclipse e selecione o arquivo em que se encontra o main() do seu projeto.
  2. Clique em Project>Properties>C/C++ Build>Settings>GCC C++ Compiler>Includes e adicione o diretório aonde se encontra a sua biblioteca boost, que deverá ser “/usr/include/boost“.
  3. Clique em Project>Properties>C/C++ Build>Settings>GCC C++ Linker>Libraries e adicione em “Libraries (-l)” “mysqlcppconn“.

Pronto, agora quando você compilar, deverá funcionar! ;)

Instalando o GLIBC 2.14 no Debian 7.2

Captura de tela de 2013-10-19 23:19:05

 

Depois de muuuuuuuuuuito tempo, com muuuuuuuuuuuita luta. FINALMENTE, eu consegui instalar o GLIBC 2.14.

Eu uso a versão wheezy, então o meu pacote libc6 tem a versão 2.13-38, ou seja, preciso adicionar ao /etc/apt/sources.list a seguinte linha:

deb http://ftp.de.debian.org/debian sid main

Se tiver alguma dúvida, basta abrir o terminal e:

  1. Digitar: “sudo gedit /etc/apt/sources.list
  2. Adicionar a linha “deb http://ftp.de.debian.org/debian sid main“.
  3. Digitar: “sudo apt-get update; sudo apt-get upgrade; sudo apt-get -f sid install libc6=2.17-93“. Confirme as perguntas, e PRONTO. Instalado!

A instalação deste pacote evita a mensagem:

“libc.so.6: version `GLIBC_2.14′ not found”

Como instalar o NetBeans IDE corretamente no Debian 7.1

Captura de tela de 2013-09-06 13:44:34

 

Sou novo com o Debian, e decidi a pouco tempo usá-lo como “sistema operacional mãe” a ponto de por ele em meu GRUB. Tive alguns problemas para instalar o JDK hoje na madrugada, e não encontrei muitos tutoriais que me explicassem o que fazer. Então, vou citar os passos logo abaixo:

  1. Baixe a versão mais recente do netbeans, você pode ir ao site, ou pode clicar aqui. (o arquivo deve ter a extensão SH)
  2. Abra o terminal como root.
  3. Digite “sudo apt-get install openjdk-7-jre”
  4. Digite “sudo apt-get install openjdk-7-jdk”
  5. Após instalar os dois pacotes, ainda pelo terminal vá até a pasta em que você colocou o arquivo SH.
  6. Digite “sh {NOME DO ARQUIVO}”.
  7. Automaticamente ele irá iniciar a instalação e você poderá proceder normalmente, sem erros.

Espero que ajude a muitos, assim como me ajudou!